Discussion:
The Exchange server address list service failed to respond.
(too old to reply)
John
2009-04-27 20:07:02 UTC
Permalink
Raw Message
Hi all,

After introducing the 2007 SP1 CAS/HUB into exchange 2003 FE/BE envir., I am
going to introduce 2007 mailbox role. At the end of the set up, there is an
error shown up:The Exchange server address list service failed to respond.
This could be because of an address list or email address policy
configuration error.
After I checked exchangesetup.log, here is the detailed info.
______________________________________________
[4/27/2009 3:04:08 PM] [2] [ERROR] Unexpected Error
[4/27/2009 3:04:08 PM] [2] [ERROR] The Exchange server address list service
failed to respond. This could be because of an address list or email address
policy configuration error.
[4/27/2009 3:04:08 PM] [2] Ending processing.
[4/27/2009 3:04:08 PM] [1] The following 1 error(s) occurred during task
execution:
[4/27/2009 3:04:08 PM] [1] 0. ErrorRecord: The Exchange server address list
service failed to respond. This could be because of an address list or email
address policy configuration error.
[4/27/2009 3:04:08 PM] [1] 0. ErrorRecord:
Microsoft.Exchange.Data.Directory.RusServerUnavailableException: The Exchange
server address list service failed to respond. This could be because of an
address list or email address policy configuration error.
at
Microsoft.Exchange.Data.Directory.Recipient.RecipientUpdateService.LocateServer()
at
Microsoft.Exchange.Data.Directory.Recipient.RecipientUpdateService.Calculate(ADObject recipient, PolicyType[] policies, ADRecipientSession session)
at
Microsoft.Exchange.Management.SystemConfigurationTasks.NewPublicFolderDatabase.PrepareDataObject()
at Microsoft.Exchange.Configuration.Tasks.SetTaskBase`1.InternalValidate()
[4/27/2009 3:04:08 PM] [1] [ERROR] The Exchange server address list service
failed to respond. This could be because of an address list or email address
policy configuration error.
[4/27/2009 3:04:08 PM] [1] Setup is halting task execution because of one or
more errors in a critical task.
[4/27/2009 3:04:08 PM] [1] Finished executing component tasks.
[4/27/2009 3:04:08 PM] [1] Ending processing.
[4/27/2009 3:04:46 PM] [0] [WARNING] Setup has made changes to operating
system settings that require a reboot to take effect. Please reboot this
server prior to placing it into production.
[4/27/2009 3:04:50 PM] [0] End of Setup
____________________________________________________
After I reboot the server, I tried to create new mailbox and unable to
create. I got the same error "The Exchange server address list service failed
to respond. This could be because of an address list or email address policy
configuration error."
Can anyone help me to resolve this issue?

BTW, Do I have to update email policy first before I introduced exchange
2007 mailbox server as I have all users hosted on the exchange 2003 BE server?

Thank you!
Ed Crowley [MVP]
2009-04-27 21:43:41 UTC
Permalink
Raw Message
Are the servers that run each of the Recipient Update Service instances
operational?
--
Ed Crowley MVP
"There are seldom good technological solutions to behavioral problems."
.
Post by John
Hi all,
After introducing the 2007 SP1 CAS/HUB into exchange 2003 FE/BE envir., I am
going to introduce 2007 mailbox role. At the end of the set up, there is an
error shown up:The Exchange server address list service failed to respond.
This could be because of an address list or email address policy
configuration error.
After I checked exchangesetup.log, here is the detailed info.
______________________________________________
[4/27/2009 3:04:08 PM] [2] [ERROR] Unexpected Error
[4/27/2009 3:04:08 PM] [2] [ERROR] The Exchange server address list service
failed to respond. This could be because of an address list or email address
policy configuration error.
[4/27/2009 3:04:08 PM] [2] Ending processing.
[4/27/2009 3:04:08 PM] [1] The following 1 error(s) occurred during task
[4/27/2009 3:04:08 PM] [1] 0. ErrorRecord: The Exchange server address list
service failed to respond. This could be because of an address list or email
address policy configuration error.
Microsoft.Exchange.Data.Directory.RusServerUnavailableException: The Exchange
server address list service failed to respond. This could be because of an
address list or email address policy configuration error.
at
Microsoft.Exchange.Data.Directory.Recipient.RecipientUpdateService.LocateServer()
at
Microsoft.Exchange.Data.Directory.Recipient.RecipientUpdateService.Calculate(ADObject
recipient, PolicyType[] policies, ADRecipientSession session)
at
Microsoft.Exchange.Management.SystemConfigurationTasks.NewPublicFolderDatabase.PrepareDataObject()
at
Microsoft.Exchange.Configuration.Tasks.SetTaskBase`1.InternalValidate()
[4/27/2009 3:04:08 PM] [1] [ERROR] The Exchange server address list service
failed to respond. This could be because of an address list or email address
policy configuration error.
[4/27/2009 3:04:08 PM] [1] Setup is halting task execution because of one or
more errors in a critical task.
[4/27/2009 3:04:08 PM] [1] Finished executing component tasks.
[4/27/2009 3:04:08 PM] [1] Ending processing.
[4/27/2009 3:04:46 PM] [0] [WARNING] Setup has made changes to operating
system settings that require a reboot to take effect. Please reboot this
server prior to placing it into production.
[4/27/2009 3:04:50 PM] [0] End of Setup
____________________________________________________
After I reboot the server, I tried to create new mailbox and unable to
create. I got the same error "The Exchange server address list service failed
to respond. This could be because of an address list or email address policy
configuration error."
Can anyone help me to resolve this issue?
BTW, Do I have to update email policy first before I introduced exchange
2007 mailbox server as I have all users hosted on the exchange 2003 BE server?
Thank you!
Rich Matheisen [MVP]
2009-04-28 01:45:10 UTC
Permalink
Raw Message
On Mon, 27 Apr 2009 13:07:02 -0700, John
Post by John
After introducing the 2007 SP1 CAS/HUB into exchange 2003 FE/BE envir., I am
going to introduce 2007 mailbox role. At the end of the set up, there is an
error shown up:The Exchange server address list service failed to respond.
This could be because of an address list or email address policy
configuration error.
Or it could be that the System Attendant service isn't running.

[ snip ]
Post by John
BTW, Do I have to update email policy first before I introduced exchange
2007 mailbox server as I have all users hosted on the exchange 2003 BE server?
No. The E2K3 address policies will be used by the E2K7 server.
---
Rich Matheisen
MCSE+I, Exchange MVP
John
2009-04-28 14:05:01 UTC
Permalink
Raw Message
thanks for your reply. Inline...
Post by Rich Matheisen [MVP]
On Mon, 27 Apr 2009 13:07:02 -0700, John
Post by John
After introducing the 2007 SP1 CAS/HUB into exchange 2003 FE/BE envir., I am
going to introduce 2007 mailbox role. At the end of the set up, there is an
error shown up:The Exchange server address list service failed to respond.
This could be because of an address list or email address policy
configuration error.
Or it could be that the System Attendant service isn't running.
[ snip ]
I double checked the service and it's running. and I even restarted the
service.
Most email policy that has (&mailnickname=*) and will "&" cause the problem?
Found this article http://forums.msexchange.org/m_1800463003/tm.htm
to clear purportedSearch attribute.
Post by Rich Matheisen [MVP]
Post by John
BTW, Do I have to update email policy first before I introduced exchange
2007 mailbox server as I have all users hosted on the exchange 2003 BE server?
No. The E2K3 address policies will be used by the E2K7 server.
Do I need to update the address policy as indicated in this
http://www.fots.nl/index.php/archive/update-legacy-email-address-policies-and-address-lists/


Thank you!
Post by Rich Matheisen [MVP]
Rich Matheisen
MCSE+I, Exchange MVP
Rich Matheisen [MVP]
2009-04-29 01:18:34 UTC
Permalink
Raw Message
On Tue, 28 Apr 2009 07:05:01 -0700, John
<***@discussions.microsoft.com> wrote:

[ snip ]
Post by John
I double checked the service and it's running. and I even restarted the
service.
Most email policy that has (&mailnickname=*) and will "&" cause the problem?
It will in that context. The "&" is the "and" condition in an LDAP
query and it makes no sense inside a parenthesized expression. It
looks like someone tried to make an alteration and botched the job.

(mailnickname=*) is correct
(&(mailnickname=*)) is also correct, but overly complicated

(&(mailnickname=*)(anotherproperty=someothervalue)) is correct

If that also shows up in your E2K3 Exchange System Manager's policy
then fix it there and let it replicate. If it's in the default policy
I don't think you'll be able to use ESM to fix it so you'll have to
use ADSIEDIT (or ldp).
Post by John
Found this article http://forums.msexchange.org/m_1800463003/tm.htm
to clear purportedSearch attribute.
I wouldn't clear the purportedSearch property, I'd just remove the "&"
and save the result.
---
Rich Matheisen
MCSE+I, Exchange MVP
h***@gmail.com
2014-06-03 12:36:03 UTC
Permalink
Raw Message
Restarting the exchange attendant service seems to fix it. Just like this post
http://heresjaken.com/the-exchange-server-address-list-service-failed-to-respond-this-could-be-because-of-an-address-list-or-email-address-policy-configuration-error/
Loading...